Utilisation GraphicsMagick 1.3.12 sur ubuntu 10.04

L ‘équipe R&D d’Easyflyer travaille d’arrache-pied à la conception d’un nouvel outil, qui sera bientôt disponible. En attendant nous avons eu de sérieux ennuis avec l’installation de la  dernière version de GraphicsMagicks sur ubuntu 10.04. La version issue du dépôt est la version 1.3.5 (pour lucid lynx), et la version nécessaire pour nous est >= 1.3.12.

Donc après une installation à partir des sources, voici l’erreur observée lors de l’utilisation :

Wrong JPEG library version: library is 62, caller expects 80

Après pas mal de recherche j’ai fini par trouver une solution.

1. Affichage des versions de librairie et des liens symboliques :

cd  ?usr?lib64

ls -la ¦ grep jpeg

cd  ?usr?lib

ls -la ¦ grep jpeg

2. les commandes doivent donner un résultat resemblant à :

3. Pour pointer sur la bonne version de librairie, il faut supprimer les liens symboliques existants et les refaire pointer vers la version 8 des librairies jpeg.

rm -rf libjpeg.so
ln -s libjpeg.so.8 libjpeg.so

4. Dernière étape, reconfigurer, et recompiler GraphicsMagick (voir ici).

 

0 Comments

Leave a Reply

Votre adresse e-mail ne sera pas publiée.

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.